We've launched Samsung Pay

For those who are not receiving the setup SMS, this is what I did to resolve it:

At first, when setting it up I wasn’t receiving the SMS that is required as part of the setup process. After several tries, it told me to phone Curve, so I did.

In troubleshooting, I was unable to delete the Curve card from the app (there is no option to delete cards when they are in a ‘to be verified’ status), so I reset the Samsung Pay app.

Then I entered the card again - and this time I did receive the SMS and the whole setup process completed, including the setup of the Curve card appearing on my Samsung Gears S3 watch.

So now it’s all working :slight_smile:

2 Likes

I have UK bin card, but when adding in Samsung pay, it’s thinking for a long while before giving me server connection error.

Email support@curve.app and they can help you add the card to Google Pay.

@Malik I don’t have problems with Google pay

Do you have a Samsung account registered in the UK? I Have UK BIN card, but I’m from Poland and probably I can see the same problem with adding the card to S Pay.

No, it’s registered in Denmark.

Hi
I have managed to add my curve card to Samsung Pay. I’m using my Samsung Galaxy gear s3 and so far only out of five shops it has only worked in one. Most of the time it will just beep but then the cashier will say that it did not go through and leisure centre said ‘card type not supported’, I will try some different shops but if this continues I will need to have a rethink on if curve is the right card for me.

Have you asked Curve support about this?

Email support@curve.app and they will be able to tell you exactly why your payments are failing.

Thanks.
I have emailed the question.
Matt

Hi Malik
I have email support like you said but I have not had a reply, Now Samsung pay on my watch is not working in any shops.
Can someone tell me why this is the case.

Can we assist @Mattman, @Curve_Marie?

@Dann @ediflyer

Have you got any errors?!

May be worth calling Support (I know it says emergency but this is the best way to deal with the issue in real time for the xpays) about this if there’s still an issue with both devices. Sometimes just deleting and re-adding the Curve card will correct an issue especially if it was already active on the device.

Hi Krzysztof,
Did you have success Curve payment in Samsung Play service in Poland?
I have Curve card with UK bin. Did l have any chance to working Curve payment on my Active 2 watch in Poland?
Regards and sorry for my english :wink:

Cześć @eupharynx,
Unfortunately no succes with setting up my Samsung Pay wallet. Tried with a few versions of the app, but it looks like it is just blocked by Samsung. And it is because their service is not offered for customers from Poland.

Samsung Pay on Phone and Watch are working only with CSC (firmware region) where Samsung Pay is officialy supported.

I use my Samsung Pay on my Phone in Bulgaria (officialy not supported) with THL CSC (changed months ago beacuse of build-in call recording).

Ceep in mind that changing phone’s CSC goes through Full Factory Reset.
There are two oprions:

  • easy: with specific region SIM card (can be also inactive/old), just reset with only sim and on startup with offer region changing.
  • complex: several firmware updates + combination firmware with AT commands (KNOX granted!, no root)

Samsung Watch CSC also can be changed (search Youtube for the specific model) and there is no need for Samsung Pay on phone (or even Samsung Phone not needed) to use Samsung Pay on Samsung Watch.

Weird issue!

I’ve been using Curve and Samsung pay for more than a month, on Samsung phone and my Samsung S3 watch, today I reset my watch and once trying to add Curve card seeing an error that card was declined by the bank. Other cars are working fine, just with Curve I started facing this issue.

I even today paid with this card, once I reset my watch this thing starts happening.

Is anybody facing same issue? I am wondering if I will reset my phone/remove my Curve card I won’t be able add it again.

Thanks!
Domas

My phone and my watch got the same error today.
Josef in Hungary