New curve card not correctly activated

Hey community,
Curve hasn’t replied to any of my three messages I have sent them since I received my card on Friday (June 26th). I was able to connect two of my credit cards to my Curve but in the app I get error messages when

  • I try to display the curve card number/cvc
  • I try to display the curve card PIN
    it says there is a problem/error and I should try later.
    So far I have
  • uninstalled and reinstalled the app
  • locked and unlocked the curve card
  • deleted and reconnected my credit cards

Please help - thank you

1 Like

There’s nothing we can do to help here as we don’t have access to accounts. In fairness they’ve been pretty busy with Wirecard over the weekend so I imagine they might be a bit slower to reply, but if you have a major issue and can’t use your card then I would suggest calling them on the number on the back. If you can use some of your linked cards then it might be worth giving support a bit longer to reply.

Hi, I got the same error. Thought first that the app is not functioning properly but with your post and my experience, it seems an error related to activation. Maybe it takes some time to fully recover.

Having the same issue. I’ve received my card during the “Wirecard outage”. I’ll bookmark this topic to see if there is any response from Curve

1 Like

Hey guys, as @ediflyer has mentioned, we don’t have access to your accounts here. Our team are super busy at the moment but you won’t be ignored, they will get back to you! These may be small hiccups as a result from our migration away from Wirecard but our team will be able to investigate further. Bear with them! :smile: