Android App 2.1.2 crashing


#1

Just got an update notification and updated the app to v 2.1.2, now it will not launch any more. Cleared app data and relaunched, no luck. Deleted the app completely and installed again from Play Store but still no joy. The app shows the splash screen but quits straight away without an error messages. Anyone else experiencing this issue? and is there a fix?


#2

I’m also experiencing this…or when I try to login , and use my Gmail - it says “access denied”. I’ve just come off the beta program to the main app


#3

Hey @Malik, thats a weird bug! I’m sure you have done but have you tried power cycling the phone?

I’ve seen this error a couple of times from other users, keep trying, someone’s app worked shortly after :slight_smile:


#4

@Dann I had uninstalled the app, rebooted phone and then installed the app. Just now I have rebooted the phone again but still the app will not launch. There have been multiple updates for the app recently and whatever the latest update was broke the app for me today. All previous updates had worked fine, one of the updates yesterday even displayed the white app icon with BETA written on the icon (I am not part of any beta as far as i’m aware) but the app still worked fine for me until today.


#5

Can you show me a screenshot of the app icon?


#6

I’ve got 2.1.3 installed, and that’s crashing on startup


#7

It no longer shows the BETA icon, just the normal app icon since I deleted and reinstalled it from Play Store.


#8

Hmm! Uninstall the curve app and then perhaps Try download Cleanmaster or something like that and see if you can see any old Curve files? then try a reboot for me, and go to the play store and download the app again?


#9

Okay i deleted the app, ran the built in cleaner in my phones to clear all obsolete files. Rebooted the phone and then installed from Play Store. This time however, app version 2.1.3 got installed from PLay Store. I was able to launch it and login okay on version 2.1.3 of the Curve App.

On a side note, app reviews on Google Play indicate that plenty of other users are experiencing the same issue.


#10

Just updated from 2.1.1 to 2.1.3, both versions work fine for me.


#11

Awesome, did we get you working @Malik?

Hey @jedihomer, could you try deleting the apps cache for me, and then deleting the Curve app, and reboot your phone and re-download from the play store?


#12

@Dann yes I am sorted now.

@Lucas 2.1.1 and 2.1.3 is also working for me. I had the problem with v2.1.2 of the app.


#13

Glad to hear it, thanks for posting!


#14

Clearing all the data sorted it


#15

Fantastic, looks like we’ve found a fix! Thanks for your input @jedihomer & @Malik!


closed #16

Bug resolved;

Clear app data, deleting and restarting the handset before downloading Curve 2.1.3 seems to fix it :slight_smile: